Mollie is down.
Incident Report for Plug&Pay Status
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 11:30 CEST
Investigating
We are currently investigating this issue.
Posted Sep 14, 2022 - 11:20 CEST
This incident affected: Mollie.