Mailgun is down.
Incident Report for Plug&Pay Status
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 23:10 CEST
Investigating
We are currently investigating this issue.
Posted Sep 21, 2022 - 20:25 CEST
This incident affected: Mailgun.