Mollie is down.
Incident Report for Plug&Pay Status
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 15:30 CEST
Investigating
We are currently investigating this issue.
Posted Sep 09, 2022 - 15:10 CEST
This incident affected: Mollie.