Plug&Pay Dashboard is down.
Incident Report for Plug&Pay Status
Resolved
This incident has been resolved.
Posted Sep 17, 2022 - 22:00 CEST
Investigating
We are currently investigating this issue.
Posted Sep 17, 2022 - 21:55 CEST
This incident affected: Plug&Pay Dashboard.